Wechseln zu: Navigation, Suche

Systemvoraussetzungen der JTL-Produkte

Verwandte Themen:


Auf dieser Seite finden Sie die Systemvoraussetzungen für unsere JTL-Produkte. Bitte beachten Sie, dass diese teilweise Richtwerte sind. Es kann also sein, dass Sie unsere Produkte auch auf Systemen mit geringeren Werten betreiben können.

Voraussetzungen für JTL-Wawi

Bei JTL-Wawi wird zwischen den Voraussetzungen für den Computer, auf dem die Datenbank betrieben wird, und für die Client-Rechner, die lediglich auf die Datenbank zugreifen, unterschieden. Bitte beachten Sie, dass Sie JTL-Wawi auch mit nur einem Computer betreiben können, der gleichzeitig als Datenbank- und Client-Rechner dient. In diesem Fall gelten jeweils die höchsten Anforderungen.

Systemvoraussetzungen für Arbeitsplätze / Clients (JTL-Wawi)

Software:

    1. Microsoft .Net Framework 4.5.2

Betriebssystem:

    1. Windows 7
    2. Windows 8, 8.1
    3. Windows 10

Systemvoraussetzungen für den Datenbankserver (MS SQL Express)

Hinweis zur Systemsprache: Wir empfehlen dringend, für den SQL-Server ein deutsches Betriebssystem (Deutsch (Deutschland)) zu verwenden.

Lesen Sie zu diesem Thema bitte auch unser Tutorial „SQL-Server für JTL-Wawi optimal einrichten“.

Microsoft SQL Server Version:

    1. Mindestens MS SQL Server 2008 R2.
    2. Empfohlen: Mindestens MS SQL Server 2016 oder 2017 Express. Wir unterstützen MS SQL Server aktuell ausschließlich unter Windows.

Für MS SQL 2016 Express werden folgende Systemanforderungen benötigt:

Software:

    1. Microsoft .Net Framework 4.5.2

Betriebssystem:

    1. Windows 7
    2. Windows 8, 8.1
    3. Windows 10
    4. Windows Server 2008 R2
    5. Windows Server 2012 / 2012 R2
    6. Windows Server 2016

Hardware:

    1. Prozessor: Intel-kompatibler Prozessor mit min. 1 GHz oder höher
    2. Arbeitsspeicher: Mindestens 512 MB RAM für SQL Server Express with Tools und SQL Server Express with Advanced Services sowie 4 GB für Reporting Services, die mit SQL Server Express with Advanced Services installiert werden
    3. Festplattenspeicherplatz: 4,2 GB Festplattenplatz + Genügend Speicherplatz für die JTL-Wawi SQL-Datenbank

Einschränkungen:

    1. Microsoft SQL Server Express unterstützt 4 Prozessorkerne, 1 GB Arbeitsspeicher und 10 GB Speicher.

Voraussetzungen für JTL-WMS

Für JTL-WMS wird grundsätzlich ein Bürorechner oder Server benötigt, auf dem die Datenbank von JTL-Wawi läuft. Des Weiteren gibt es Anforderungen an die einzelnen Packplätze, mobile Geräte und das Netzwerk, über das alle Rechner miteinander verbunden sind.

Netzwerk

LAN:

    1. Gigagbit-LAN oder besser

WLAN:

    1. Bevorzugt im 5-GHz-Band
    2. Access Points müssen bei Verwendung der JTL-WMS Mobile App das Hand-Over-Protokoll unterstützen

Packtisch-Rechner

    1. Prozessor: Intel i3 oder besser
    2. Arbeitsspeicher: 4 GB RAM
    3. Grafikkarte: Mindestens 128 MB Grafikspeicher

Tablets / Kombigeräte

Wir empfehlen grundsätzlich keine Multimedia-Tablets, da diese in der Regel zu viel störende Software im Auslieferungszustand haben und deren Akkulaufzeit stark beschränkt ist.

    1. Prozessor: 1,5 GHz DualCore oder besser
    2. Display: 4,5 Zoll oder größer
    3. Arbeitsspeicher: 1 GB, empfohlen: 2 GB
    4. WLAN: 5 GHz WLAN

Bildschirmauflösung

Die verwendeten Monitore müssen mindestens eine Bildschirmauflösung von 1280x780 unterstützen. Empfohlen wird hier jedoch eine Auflösung von 1920x1080. Da JTL-WMS auf Bedienung von Touch-Monitoren ausgelegt ist, wurden viele Kontrollelemente wie Buttons und Listen sehr groß gehalten. Daher wird eine hohe Auflösung für eine gute Übersicht dringend empfohlen.

Voraussetzungen für JTL-Shop

Internetanbindung

    1. Uploadgeschwinidigkeit von 2 MBit/s, empfohlen: 6 MBit/s

In der Regel ist die Downloadgeschwindigkeit Ihrer Internetverbindung nicht relevant, da sie normalerweise deutlich höher als die Uploadgeschwindigkeit ist.

Server

Hinweis:

Die Systemvoraussetzungen stellen das offiziell unterstützte, empfohlene und supportete Setup für den Betrieb von JTL-Shop dar. Der Betrieb auf ähnlichen Setups (Windows, FreeBSD, sunOS, nginx, PHP-FPM) ist zwar generell möglich, jedoch können wir dafür keinen Support für die Einrichtung und / oder daraus entstehenden Problemen mit der Software anbieten.

Alternative HTTP-Server (z.B. NGINX / PHP-FPM): Bitte beachten Sie, dass die .htaccess-Regeln (u. a. zum Verzeichnisschutz!) bei diesen Servern manuell durch entsprechende ProxyPass-Regeln nachgetragen werden müssen.
Bitte beachten Sie:
Die Community Free Edition von JTL-Shop funktioniert nur mit JTL-Wawi ab Version 1.0.

Bitte stellen Sie sicher, dass die folgenden Systemvoraussetzungen von Ihrem Webserver erfüllt werden:

    1. Betriebssystem: Linux (Debian, Ubuntu, etc.) (Bitte oben aufgeführte Hinweise beachten)
    2. Apache-Webserver (PHP-Mode: FCGI oder Apache Module) mit mod_rewrite-Modul
    3. Datenbank: MySQL oder MariaDB ab Version 5.x
    4. PHP-Version: JTL-Shop 4.00 benötigt mindestens PHP 5.4, empfohlen: PHP 7.0

Exkurs: Welche PHP-Version wird unterstützt?

PHP 5.2 PHP 5.3 PHP 5.4 PHP 5.5 (ionCube >= 4.5) PHP 5.6 (ionCube >= 4.5) PHP 7.0
Shop 3.16 Ja Ja Nein Nein Nein Nein
Shop 3.17 Ja Ja Ab Build 4 Nein Nein Nein
Shop 3.18 Ja Ja Ja Nein Nein Nein
Shop 3.19 Ja (Sofern NICHT die alternativen Dateien verwendet werden) Ja Ja Mit alternativen Shopdateien Mit alternativen Shopdateien Nein
Shop 3.20 Nein Ja Ja Ja Ja Nein
ab Shop 4.00 Nein Nein Ja Ja Ja Ja
    1. Mailserver: Lokal oder per SMTP erreichbar
    2. PHP-Module:
      1. GD Lib
      2. SimpleXML
      3. ImageMagick
      4. Imagick
      5. Curl
      6. Iconv
      7. MBString
      8. Tokenizer
      9. PDO (MySQL)
      10. IonCube-Loaders ( http://www.ioncube.com/loaders.php Der JTL-Shop 4 wird mit offenem Quelltext ausgeliefert und ist ohne IonCube-Loader betriebsbereit. Ein IonCube-Loader wird unter Umständen jedoch für den Betrieb von Drittanbieter-Plugins benötigt.
    3. PHP-Einstellungen:
      1. PHP-Skript-Ausführungszeit (max_execution_time) mindestens 120 Sekunden
      2. PHP-Speicherlimit (memory_limit) mindestens 128 MB
      3. Maximale PHP Übertragungsgröße (FILE / upload_max_filesize) mindestens 6 MB
      4. Maximale PHP Übertragungsgröße (POST / post_max_size) mindestens 8 MB
      5. allow_url_fopen aktiviert (wenn Zahlungsart Saferpay genutzt werden soll)
      6. magic_quotes_runtime deaktiviert (Seit PHP 7.0 ist diese Einstellung entfernt)

Exkurs: Benötigter Webspace

Für wie viele Artikel wie viel Webspace benötigt wird, lässt sich nur theoretisch rechnerisch bestimmen. Ausschlaggebend sind nicht die Artikel selbst, sondern hauptsächlich deren Bilder. Artikelbilder werden in Originalgröße auf dem Webspace abgelegt und zusätzlich je Shop-Sprache in vier verschiedenen Größen skaliert gespeichert.

So ergibt sich bei einer Shopsprache je nach Ziel-Bildgrößen und Qualität das 2-3 fache der Originalbild-Dateigrößen für den benötigten Webspace.

Beispiel:

    1. Eine Shopsprache
    2. 200 KB durchschnittliche Originalgröße
      1. Artikelbilder, die in JTL-Wawi bei den Artikeln hinterlegt werden
      2. Denken Sie darüber nach, was Sie den Kunden für Bildgrößen liefern wollen. Wenn Sie Full-HD Bilder bereitstellen wollen, sollten Sie keine speicherhungrigen 4k-Bilder in JTL-Wawi hinterlegen
      3. Achten Sie darauf, dass die Bilder gut komprimiert sind (zulässige Dateiformate für Artikelbilder sind .jpg/.jpeg und .png)
    3. Im Shop wird eingestellt, dass die größte Anzeigeform für Artikelbilder der Originalgröße in JTL-Wawi entspricht
Mit diesen Voraussetzungen würden 10GB Webspace für etwa 17000 bis 25000 Artikelbilder reichen.

Hinweis zur Shop-Domain: Wir raten dringend davon ab, für Ihren Shop eine Domain mit Umlauten / Sonderzeichen zu verwenden. Diese führen immer wieder zu Problemen. Ein fehlerfreier Einsatz kann leider nicht gewährleistet werden. Es sind z.B. kritische Probleme mit dem JTL-PayPal-Plugin zu erwarten. Wir empfehlen stattdessen als Hauptdomain eine Domain ohne Umlaute / Sonderzeichen und die anderen Domains nur als Aliasdomains zu verwenden, die auf die Hauptdomain weiterleiten.

Webhosting-spezifische Voraussetzungen:

Info für All-Inkl Webhosting-Kunden: Stellen Sie sicher, dass Ihr Server PHP5 voreingestellt hat. Falls Sie sich nicht sicher sind, bitten Sie den All-Inkl Support dies zu prüfen und ggf. einen Umzug auf einen Server mit voreingestelltem PHP5 vorzunehmen.

Unserer Erfahrung nach gibt es Probleme bei Servern mit sunOS und dem IonCube-Loader! Bitte erkundigen Sie sich vor der Shop-Installation bei Ihrem Hoster, welches Betriebssystem auf dem Server eingesetzt wird, wir empfehlen den Einsatz von Linux-Webservern.

Info für 1&1-Hosting-Kunden: Bei 1&1-Hosting-Kunden sind nach Installation des JTL-Shop zusätzliche Schritte erforderlich, um ionCube zu aktivieren, siehe JTL-Shop auf einem Server von 1und1 oder Strato betreiben

Info für Strato Managed Virtual Server Kunden: Bei der Installation des Shops/IonCube muss "PHP-Modus und -Beschleuniger" auf CGI stehen. Für die Nutzung des SEO-Moduls muss der Modus dann wieder auf "Fast CGI + APC" gesetzt werden.


Wie geht es weiter?